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Microchip 社製 PIC32MX 32 ビット MCU への

Helix MP3 デコーダの移植 

注意 : この日本語版文書は参考資料としてご利用ください。最新情報は必ずオリジ
ナルの英語版をご参照願います。
はじめに
MPEG-1、MPEG-2、MPEG-2.5 Layer 3 (MP3) オーディ
オ エンコーディング フォーマットは、コンシューマ向
けのオーディオ ストレージやデジタル オーディオ プ
レーヤで広く用いられているオーディオ フォーマット
です。各種のビットレート ( 可変ビットレートも可能 )
とオーディオ サンプリング レートが使える MP3 アル
ゴリズムは、幅広いマルチメディア アプリケーション
に適しています。

本書では、オープンソースの Helix MP3 デコーダ アル
ゴリズムを Microchip 社製 PIC32MX 32 ビット マイク
ロコントローラ(MCU)に移植する方法について説明し
ます。本書には、Helix MP3 デコーダを使った MP3 プ
レーヤ アプリケーションのデモ用ソースコードが付
属します。この MP3 プレーヤ アプリケーションは、
USBフラッシュ ドライブ (本書ではサムドライブと呼
ぶ ) から MP3 ファイルを読み出すために Microchip 社
製 USB スタックを使用し、タッチスクリーン対応の
グラフィカル ユーザ インターフェイス(GUI)を実装す
るために Microchip 社製グラフィック スタックを使用
します。 

場合によっては、アプリケーションの目標要件を満たす
ために、オープン ソースコードにお客様独自のコード
を追加する事が必要です。オープン ソースコードと一
緒に静的コンパイルする場合、この独自コードはオープ
ンソースのエンドユーザ ライセンス契約の対象となる
場合があります。多くの場合、これはアプリケーション
所有者には受け入れられません。従って本書では、アプ
リケーションの知的所有権を保護可能とする RTLL
(Run-Time Library Loading) 方式について説明します。  

本書の構成は以下の通りです。 

1. Helix MP3 デコーダ ライブラリの説明

2. デモ アプリケーションでの RTLL 方式の使用

3. デモ アプリケーション コードの説明

4. デモ アプリケーションのコンパイル / 実行手順

HELIX MP3 デコーダについて
Helix MP3 デコーダは、浮動小数点対応と固定小数点対
応の双方で実装可能です。PIC32MXマイクロコントロー
ラへのアルゴリズムの移植には、固定小数点実装を使い
ます。このアルゴリズムは全ての 32 ビット固定小数点
プロセッサで動作します。コードは全て C 言語で書か
れていますが、一部のコードは最適化したアセンブリ
命令に置き換える事も可能です。

Helix MP3 デコーダは MPEG1、MPEG-2、MPEG-2.5 向
けの Leyser 3 をサポートします。このデコーダは可変
ビットレート、固定ビットレート、ステレオおよびモ
ノラル オーディオ フォーマットをサポートします。実
装と機能の詳細については、Helix MP3 デコーダのウェ
ブサイト (https://datatype.helixcommunity.org/Mp3dec)
をご覧ください。

Helix MP3 デコーダのソースコードはオープンソー
スであり、付属するファイルに記載されたライセンス
条件が適用されます。Helix MP3 デコーダは無償で使
えるオープンソースですが、MP3 アルゴリズム自体
は無償ではなく、ロイヤルティが発生します。MP3
アルゴリズムを使うには、これらのロイヤルティを支
払う必要があります。詳細は www.mp3licensing.com
をご覧ください。

PIC32MX マイクロコントローラへの
Helix MP3 デコーダの移植
PIC32MX プラットフォームに移植する Helix MP3 デ
コーダ ソースコードは、Helix MP3 デコーダのウェ
ブサイトからダウンロードできます。ウェブページの
指示に従ってソースコードをダウンロードしてくだ
さい。あるいは、本書に付属する Helix MP3 デコー
ダ ソースコードを使う事もできます。このソース
コードは、PIC32MX デバイス上で Helix MP3 デコー
ダが動作できるように変更済みです。最新のソース
コードについては、Helix MP3 デコーダのウェブサイ
ト (https://datatype.helixcommunity.org/Mp3dec) をご
覧ください。

ダウンロードしたソースコード内の各フォルダには、
3 つのライセンス ファイル (RPSL.txt、RCSL.txt、
LICENSE.txt) が保存されています。ユーザには、これ
らのライセンス ファイルの記載事項に同意する事が求
められます。

Author: Sunil Fernandes
Microchip Technology Inc.
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Helix MP3 デコーダのウェブサイトからダウンロード
した場合、 ソースコードは「fixpt」フォルダ内にあ
ります。デコーダ ソースコードを PIC32MX に移植す
る手順は以下の通りです。

1. 「\fixpt\real」フォルダ内の assembly.hファ
イルを開く。

2. MIPSプラットフォーム向けのFASTABS関数定義
( このファイルの行 337) へ移動する。
この関数は、MIPS アセンブリで書かれた絶対関
数です。

3. この関数のボディをコメント化し、C コードで置
き換えた後に ( 例 1)、ファイルを保存する。

4. 「fixpt」フォルダ内の mp3dec.c ファイルを開
き、行 47 をコメント化する ( 例 2 参照 )。
Helix MP3 デコーダを PIC32MX に移植する場合、
この機能は不要です。 

これらの手順は、バージョン 1.8 の assembly.hファ
イルとバージョン 1.6 の mp3dec.cファイルに適用さ
れます。

以上は、Helix MP3 デコーダのウェブサイトからダウ
ンロードしたソースコードに必要な変更内容です。本
書に付属する Helix MP3 デコーダ ソースコードには、
これらの変更を適用済みです。

例 1:  

例 2:  

static __inline int FASTABS(int x) 
{
// int t=0; /* Really is not necessary to initialize only to avoid warning.*/
//
// __asm__ volatile (
// "sra %0, %1, 31 \n\t"
// "xor %1, %1, %0 \n\t"
// "sub %0, %1, %0 \n\t"
// :"=&r" (t) 
// :"r" (x)
//  );
//
// return t;
    

/* Commented out the above code as it causes problems while decoding some files */
/* on MIPS M4K core.*/

    return((x > 0) ? x :-(x));
}

#include "string.h" /* for memmove, memcpy (can replace with different */ 
/* implementations if desired) */

#include "mp3common.h" /* includes mp3dec.h (public API) and internal, */
/* platform-independent API */

//#include "hxthreadyield.h"
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Helix ソースコード ファイルを含めたプロジェクトを
ビルドするには、「fixpt」および「fixpt\real」フォ
ルダ内の全ての「.c」ソースコード ファイルをインク
ルードする必要があります。必要に応じて、プロジェ
クトに全てのヘッダファイルをインクルードできま
す。図 1 は、MPLAB IDE の「Project Explorer」ウィ
ンドウに表示されたファイルリストです。

図 1:   「PROJECT EXPLORER」ウィンドウ

「fixpt\pub」および「fixpt\real」フォルダのパ
スは、プロジェクト ファイル格納位置からの相対パス
で指定する必要があります。
Project>Build Options>Project をクリックし、[Directories]
タブで「Include Search Path」を選択し、フォルダの
パスを MPLAB プロジェクトの格納位置に対する相対
パスで指定します ( 絶対パスで指定する事も可能 )。プ
ロジェクト フォルダと「fixpt」フォルダが同じフォ
ルダ内にある場合のオプション選択の例を図 2 に示し
ます。

図 2: インクルード ファイルの検索パスを指定する

コンパイルする際に、MIPS シンボルを定義する必要
があります。これにより、Helix MP3 デコーダ ソース
コードを PIC32MX プラットフォーム向けにビルドし
ます。
Project>Build Options>Project をクリックし、「MPLAB
PIC32 C Compiler」タブで、MIPS マクロをビルドプ
ロセスに追加します ( 図 3 参照 )。

図 3:   ビルド オプションに MIPS プリプロセッ
サ マクロを追加する
 2014 Microchip Technology Inc. DS01367A_JP - p. 3
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このデコーダの動作にはヒープメモリが必要です。デ
コーダに必要なヒープメモリのサイズ ( 入出力バッ
ファを含まず ) は 28 KB です。コンパイル時に、この
値をヒープサイズとして指定する必要があります。
Project>Build Options>Project をクリックし、「MPLAB
PIC32 Linker」タブを開き、図 4 のように [Heap size]
を指定します。

図 4:   ヒープメモリのサイズを指定する

Helix MP3 デコーダのソースコードは、最適化レベルを
「O3」に設定してコンパイルします。
Project>Build Options>Project をクリックし、「MPLAB
PIC32 C Compiler」タブを開き、[Categories] フィー
ルドでドロップダウン リストから「Optimization」を選
択します。最適化レベルは「O3」に設定します ( 図 5
参照 )。

以上により、Helix MP3 デコーダ ソースコードを
PIC32MX アプリケーションで使うための準備が完了
します。

図 5:   コンパイラの最適化レベルを設定する

Helix MP3 デコーダ API 
(Application Program Interface)
Helix MP3 デコーダ API は以下を実行するための関数
を提供します。

• デコーダの初期化

• デコーダの終了

• フレーム同期の検出

• フレーム情報 ( ビットレート、サンプリング レート
等 ) の取得

• MP3 フレームのデコード

Helix MP3 デコーダを使用するための最初の手順は、
デコーダ API を呼び出すために、必要なヘッダファイ
ルを全てのソースファイルにインクルードする事で
す。インクルードする必要があるファイルは、
coder.hと mp3dec.hです ( 例 3 参照 )。

例 3:  

注意 : デモ アプリケーションは、RTLL 方式を使っ
て、システムローダ インターフェイス経由で
間接的に Helix MP3 デコーダ API を呼び出し
ます。このため、MEB USB Thumb Drive MP3
C32 Demo.mcpソースコードは、Helix MP3 デ
コーダ API を直接呼び出すためのインター
フェイスを備えていません。

// The following files must be 
// included in the source code to 
// invoke the Helix MP3 decoder API

#include "coder.h"
#include "mp3dec.h"
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AN1367
Helix MP3デコーダは完全リエントラントです。これは、
デコーダステートがデータ構造体内に完全に格納され
る事を意味します。MP3InitDecoder()関数は、メモ
リをこのデータ構造体用に割り当てて初期化した後
に、初期化済みデータ構造体へのポインタを返します。
この関数は動的メモリ割り当てを使い、ヒープメモリ
の割り当てを必要とします。割り当てに失敗した場合、
この関数は値「0」を返します ( 例 4 参照 )。

アプリケーションでデコーダの動作を終了する場合、
MP3FreeDecoder() 関数を使う事で、デコーダに割
り当てたメモリを解放できます ( 例 5 参照 )。この関数
は、デコーダが使っていたメモリをクリアします。

通常、MP3 ファイルには、ID3 タグ形式の追加情報
が書き込まれています。これらのタグは曲名、アー
ティスト、アルバム、ジャンル等の情報を格納しま

す。Helix MP3 デコーダ関数へ入力されるフレームは
この情報を含みません。アプリケーションは、ファイ
ルまたは入力ストリーム内で実際に MP3 データが始
まる位置を特定する必要があります。これには
MP3FindSyncWord()関数を使います。この関数は、
入力バッファ(MP3ファイルからのバイト読み出しの
一部 ) を受け取り、MP3 フレームヘッダ内で同期ワー
ドの位置を特定し、その位置を入力バッファの先頭か
らのオフセットとして返します。同期ワードは PM3
フレームの先頭を示します。負の値が返された場合、
入力バッファには同期ワードまたは MP3 フレームの
先頭が含まれていなかった事を意味します(例6参照)。

例 4:  

例 5:  

// Initialize the Helix MP3 decoder.This will point to the MP3 decoder data
// structure.

HMP3Decoder mp3Decoder;
mp3Decoder = MP3InitDecoder();
if(mp3Decoder == 0)
{
// This means the memory allocation failed.This typically happens if there is not
// enough heap memory.Recompile the code with additional heap memory.

while (1);
}

// Close the decoder.

MP3FreeDecoder(mp3Decoder);

// At this point, memory consumed by the MP3 decoder is released.
 2014 Microchip Technology Inc. DS01367A_JP - p. 5
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例 6:  
// Find a valid MP3 start of frame in the input stream

while(!endOfFile(mp3File))
{

// Read the input file

nRead = fread(mp3File,input,MAX_FRAME_SIZE);
if(nRead == 0)
{

// We have reached end of file and a valid MP3 start of frame was not found. 
// Do something.

NotValidMP3File();
break;
}
else
{

offset = MP3FindSyncWord(input,MAX_FRAME_SIZE);
if(offset < 0)
{

// The input buffer does not contain a start of frame.Read another frame.

continue;
}
else
{

// We found a start of frame. offset contains location of the start of frame
 // within input buffer.

foundStartOfFrame = TRUE;
break;
}

}
}

DS01367A_JP - p. 6  2014 Microchip Technology Inc.
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MP3FindSyncWord() 関数が同期ワードを検出した
としても、それが MP3 フレームの実際の先頭ではな
い可能性があります。ID3 タグ内の何らかのデータが
同期ワードに一致するといったケースが生じる可能性
があります。そのような場合、その入力が MP3 デコー
ダ関数に引き渡されると、エラーが返されます。アプ
リケーションは、このエラーを適切に処理する必要が
あります。

本書に付属する MP3 プレーヤ アプリケーションは、
44.1 kHzでサンプリングされ、ステレオ形式でエンコー
ドされた MP3 ファイルを処理するよう設計されていま
す。Helix MP3 デコーダは、処理前の MP3 フレームの
オーディオ属性を返すMP3GetNextFrameInfo()関数
を備えています。アプリケーションは、必要に応じて
この情報を使う事ができます。
MP3FindSyncWord() 関数は、SOF (Start of Frame)
の位置を特定する事で、MP3 フレームを示します。
MP3GetNextFrameInfo() 関数を使うと、デコード
前の MP3 フレームに関する情報を抽出できます。こ
の情報は、MP3FrameInfo型データ構造体で返されま
す。MP3 フレームが無効な場合、エラーが返されます
( 例 7 参照 )。 

MP3FrameInfo 型データ構造体からは以下の情報が
得られます。

• 処理されたフレームのビットレート

• オーディオ チャンネルの数 (1: モノラル、2: ステレ
オ )

• エンコード時のオーディオ サンプリング レート

• サンプルあたりのビット数

• デコードされたオーディオ フレームのサイズ (オー
ディオ サンプルの数 ) ( ステレオ サンプルは 2 個と
して数える )

• MPEG レイヤ

• レイヤ バージョン

MP3GetLastFrameInfo() 関数は、デコード後の
オーディオ フレームの情報 ( 内容は上記と同じ ) を返
します。例 8 に、MP3GetLastFrameInfo() 関数の
使用方法を示します。

例 7:  

例 8:  

// Get information about the next frame to be decoded.This assumes that the 
// MP3FindSyncWord()function has been used to locate the start of a MP3 frame.

MP3FrameInfo frameInfo;

if(foundStartOfFrame == TRUE)
{

int error;
error = MP3GetNextFrameInfo(mp3Decoder, &frameInfo, input);
if(error == MP3_INVALID_FRAME_HEADER)
{

// This means that the MP3FindSyncWord function has found the sync word, 
// but this was not a start of frame.This may have happened because 
// the sync word may have found in an ID3 tag.

GetAnotherFrame();
}

else if(frameInfo.sampRate != 44100)
{

// For this example, we want only data which
// was sampled at 44100 Hz.Ignore this frame.

IgnoreThisFrame();
}

}

// Get information about the last decoded frame.It is assumed that the frame was 
// decoded by calling the decode function.

MP3FrameInfo mp3frameInfo;
int nOutputSamples;

MP3GetLastFrameInfo(mp3Decoder, &mp3FrameInfo);

// Get the size of the output raw audio frame.

nOutputSamples = mp3FrameInfo.outputSamps;
 2014 Microchip Technology Inc. DS01367A_JP - p. 7
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MP3Decode()関数は、エンコードされた MP3 フレー
ムをデコードします。この関数は、コア MP3 デコー
ディング アルゴリズムを呼び出します。1 回のデコー
ド動作では、入力エンコード フレームの全体を処理で
きない場合があります。その場合、入力ポインタは未
処理バイトの先頭へ進みます。デコーダ関数は、未処
理バイトの総数も返します。MP3 アプリケーション
は、この情報に基づいて入力バッファを準備できます。
適正な動作を得るには、新しいデータを未処理バイト
の最後に追加する必要があります。

入力フレームは、独立 MP3 フレーム向けに標準 MPEG
ストリームとしてフォーマットできます。標準 MPEG
ストリーム フォーマットはMP3プレーヤで幅広く使わ
れています。デコード後の RAW データのフォーマット
は、オーディオ チャンネルの数によって異なります。
モノラル オーディオデータの場合、オーディオ サンプ
ルは連続して出力されます。ステレオ オーディオデー
タの場合、左 / 右チャンネルのオーディオ サンプルが
交互に (LRLRLR…) 出力されます。デコード関数は、デ
コード処理の結果を示すエラー値を返します。MP3 ア
プリケーションは、エラーのタイプに応じて適切な
対応を実行できます ( 例 9 参照 )。

例 9:  
// Decode a MP3 frame.It is assumed that the MP3FindSyncWord() function was used
// to find a start of frame.

short output[MAX_NCHAN * 1152];
int err;
int bytesLeft

bytesLeft = INPUT_BUF_SIZE;
err = MP3Decode(mp3Decoder, &input, &bytesLeft, output, 0);

// bytesLeft will have number of bytes left in the input buffer.Input buffer will 
// point to the first unconsumed byte.

// This code example shows how the errors can be handled. 
// This may differ between applications.

switch(err)
{

case ERR_MP3_INDATA_UNDERFLOW:
CloseMP3File();
break;

case ERR_MP3_MAINDATA_UNDERFLOW:
ReadMoreMp3Data();
break;

case ERR_MP3_FREE_BITRATE_SYNC:
CloseMP3File();
break;

default:
CloseMP3File();
break;

}

// The MP3GetLastFrameInfo() function can be used to obtain information about the 
// frame.The following shows an example.

MP3GetLastFrameInfo(mp3Decoder, &mp3FrameInfo);
if(mp3FrameInfo.outputSamps != 0)
{

// Write data to output DAC

WriteDataToDAC(output, mp3FrameInfo.,outputSamps);
}

DS01367A_JP - p. 8  2014 Microchip Technology Inc.
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表 1 に、PIC32MX マイクロコントローラ上で Helix
MP3 デコーダが動作する場合のメモリ要件を示しま
す。表 2 に、計算性能要件を示します。

RTLL (RUNTIME LIBRARY LOADING)
アプリケーションにオープン ソースコード コンポー
ネントを使う場合、使う場合、お客様独自のアプリケー
ション コードにオープン ソースコードのライセンス
条件が適用される可能性があります。これは、アプリ
ケーションの開発者または所有者にとって不都合かも
しれません。このため、本書のソースコードに付属す
る MP3 アプリケーション サンプルでは、以下の手法
を使います。

• オープン ソースコードをメインのアプリケーショ
ン ソースコードにリンクしない ( 別々にコンパイル
し、互いにリンクしない )。

• ローダ ユーティリティを使って、実行中にオープン
ソースコード ライブラリを一連の関数ポインタと
して読み込む。

この手法をRTLL (Run-Time Library Loading)と呼びま
す。MP3 プレーヤ アプリケーションは、RTLL 方式を
使って、実行中に Helix MP3 デコーダを読み込みます。
図 6 に、RTLL 動作の概念図を示します。

RTLL 方式では、システムローダを使って Helix MP3
デコーダを読み込みます。読み込みプロセス中に RAM
を初期化し、プログラムメモリから RAM へテーブル
をコピーし ( 必須ではない )、デコーダからエクスポー
トされた関数への一連のポインタを取得します。MP3
プレーヤ アプリケーションは、システムローダを使っ
て自身の関数をエクスポートする事で、Helix MP3 デ
コーダからそれらの関数を呼び出せるようにします。
同様に、Helix MP3 デコーダ モジュールにコードを追
加する事で、デコーダからシステムローダを介して一
連の関数をエクスポートし、メイン アプリケーション
からそれらの関数を呼び出せるようにします。

MP3 プレーヤ アプリケーションは 2 つのプロジェク
トを含み、それらは 2 つの異なる HEX ファイル ( プロ
グラム イメージ ) を生成します。1 つのファイルはメ
イン アプリケーション用 (USBおよびグラフィック ス
タックも含む ) に使い、もう 1 つのファイルは Helix
MP3 デコーダ用に使います。これら 2 つのプログラム
イメージは、デバイス プログラムメモリ内の別々の領
域に書き込まれます。このため MP3 アプリケーショ
ンは、RTLL 方式を使って Helix MP3 デコーダにアク
セスします。この方式を使うには、C32 リンカが使用
する既定値リンカスクリプトを変更する必要がありま
す。RTLL 方式を実装するプログラム フラッシュおよ
びデータ RAM セクションの開始位置を調整する必要
があります。Helix MP3 デコーダ向けのこれらのセク
ションは、それぞれのメモリ領域の最後に配置されま
す。Helix MP3 デコーダ向けのプログラムメモリ領域
は、プログラムメモリの最後から 72 K バイト手前の位
置で始まるよう設定され、Helix MP3 デコーダ向けの
データ RAM 領域は、KSEG1 RAM の最後から 256 バイ
ト手前の位置で始まるよう設定されます (Helix 用に十
分なスタックメモリを確保 )。同様に、MP3 プレーヤ
プログラム イメージを作成する際に使うリンカスク
リプトは、Helix MP3 デコーダを格納するためにサイ
ズを調整します。その結果、MP3 アプリケーション向
けのプログラムメモリは 72 K バイト減少し、KSEG1
RAM は 256 バイト減少します。

本書内の以降の説明では、「メイン アプリケーション」
は MP3 プレーヤ アプリケーションを指し、「ライブラ
リ」は Helix MP3 デコーダを指します。これら 2 つを総
称して「モジュール」と呼びます。RTLL 方式は、動的
なモジュール ヘッダデータ構造体 (module_dyn_hdr)
を使って、モジュールに関する情報を保持します。メ
イン アプリケーション、システムローダ、ライブラリ
はそれぞれに固有の動的モジュールヘッダを有しま
す。例 10 に、module_dyn_hdrの定義を示します。

表 1:  HELIX MP3 デコーダのメモリ要件

メモリタイプ
容量 

( バイト )
備考

プログラム
メモリ

53000 —

データメモリ 28000 デコーダのみによる要求

入力バッファ 1940 最大 MP3 フレームサイズ

出力バッファ 2304 出力バッファが要求する最
大容量 ( ステレオ オーディ
オデータの場合 )

表 2:  HELIX MP3 デコーダの計算性能要件

関数 MIPS 備考

MP3Decode() 26 最適化レベル「O3」でコ
ンパイルしたコードを
使って、80 MHz のプロ
セッサ クロックで計算
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図 6:   RTLL フレームワーク

例 10:  

各モジュールの動的ヘッダデータ構造体は、インポー
トおよびエクスポートされた関数に関する情報を格納
します。インポートされた関数は、モジュール イン
ポート テーブル (module_import_tbl) に含まれま
す。エクスポートされた関数は、モジュール エクス
ポート テーブル (module_export_tbl) に含まれま
す。例 11 に、メイン アプリケーション モジュール向
けに動的ヘッダを初期化する方法を示します。

例 11:  

MP3 Player Application System Loader Helix MP3 Decoder
Loader Calls Loader Calls

Application Calls

Library Calls

typedef struct
{

// module signature
const char module_sign[_MCHP_DYN_HDR_SIGNATURE_SIZE_];

// name of the module
const char module_name[_MCHP_MODULE_NAME_SIZE_];

// pointer to module init
const module_init_dcpt* module_init;

// pointer to the export descriptor
const export_dcpt*      module_export_tbl;

// pointer to the import descriptor
const import_dcpt*      module_import_tbl;

// pointer to module data
module_data_dcpt*       module_data;

// module info
const module_info_dcpt  module_info;

}module_dyn_hdr;

const module_dyn_hdr __attribute__((__section__(".Module_Header_Section"))) _ModuleLoadHdr = 
{

_MCHP_DYN_HDR_SIGNATURE_,           // signature
MAIN_SERVICES_LIB,                  // lib_name
0,                                  // module init
&SystemExports,                     // exports
&_DefaultModuleImports,             // imports
&module_data,                       // private data
_DefaultModuleInfo(0x0100),         // module info

};
DS01367A_JP - p. 10  2014 Microchip Technology Inc.
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メイン モジュールは、Helix MP3 ライブラリが必要とす
る malloc()および free() 関数をエクスポートしま
す。メイン アプリケーション モジュールは、他のモ
ジュールの関数を一切インポートしません。このため、
_DefaultModuleImportsテーブルは空白です。RTLL
方式を使うと、システムローダを 1 つのモジュールと
して読み込む事ができます。しかし本書のアプリケー
ション例ではこの方法を採らず、システムローダをメ
イン アプリケーション モジュールへ静的にリンクして
います。この選択は、メイン アプリケーション モジュー
ルのコンパイル時に LOADER_STATIC_LINK オプショ
ンで指定します。

メイン アプリケーションは、RTLL システムを初期化
するために、dlopen()関数 (AudioUSBTasks.cファ
イル内の AudioUSBInit() 関数内 ) を呼び出します
( 例 12 参照 )。

dlopen()関数は、p_modules[]配列で指定されてい
る全てのモジュールを読み込みます。読み込みの際に、
各モジュールに対応する起動コード ( 存在する場合 )
が呼び出されます。Helix MP3 ライブラリ モジュール
は、変更された C ランタイム起動コードを使って、割
り当てられたメモリを初期化します。その後
dlopen()関数は、Helix MP3 ライブラリ モジュール
の動的ヘッダを指すポインタを返します。

メイン アプリケーションは、次にdlsym()関数を使っ
て、Helix MP3 ライブラリ モジュール エントリポイン
トへのハンドルを取得します ( 例 13 参照 )。

これは、helix_lib.c ファイルで定義されている
HelixLibEntry() 関数を指すポインタを返します。
この関数は、指定されたアルゴリズムに基づいて、
Helix MP3 デコーダ API を呼び出します。例 14 に、
HelixLibEntry()関数実装の一部を示します。

HelixLibEntry() 関数の引数 fCode は、呼び出す
Helix ライブラリ関数を指定します。fCodeが「0」の
場合、MP3InitDecoder() 関数を呼び出します。メ
イン アプリケーション モジュールは、システムロー
ダ dlsym() を呼び出す事で、HelixLibEntry() 関
数へのハンドル (MP3DecoderFunctions) を取得す
る事に注意してください。

メイン アプリケーション モジュールは、取得した
MP3DecoderFunctions ハンドルを使って、Helix
MP3 デコーダ API 関数を呼び出します。

例 15 に、メイン アプリケーション モジュールから
MP3DecoderFunctions ハンドルを使って
MP3Decode() 関数を呼び出す方法を示します。

例 12:  

例 13:  

例 14:  

例 15:  

/* Get a handle to the MP3 decoder and obtain an entry point to the decoder
 * Library functions.*/

hMP3DecoderLibrary = dlopen("Helix Library", 0)

MP3DecoderFunctions = (void* (*)(int, int, ...))dlsym( 
hMP3DecoderLibrary, "HelixLibEntry");

void* HelixLibEntry(int fCode, int nparams, va_list args)
{

void*   res = (void*)-1;

// Library entry point
switch(fCode)
{

case 0:
if(nparams == 0)
{

res = MP3InitDecoder();
}
break;

case 1:
if(nparams == 1)
{

MP3FreeDecoder(va_arg(args, HMP3Decoder));
res= 0;

}
break;

// MP3_DECODE_FUNCTION is fCode value for MP3Decode() function.
// The second argument indicates the total number of arguments that follow.

err = (int)(*MP3DecoderFunctions)(MP3_DECODE_FUNCTION,5,hMP3Decoder, &readPtr, &bytesLeft, 
outBuf, 0);
 2014 Microchip Technology Inc. DS01367A_JP - p. 11
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MP3 プレーヤ アプリケーション
MP3 プレーヤ アプリケーションは、Helix MP3 デコー
ダ (RTLL 経由 ) と Microchip 社製 USB スタックおよび
グラフィック スタックを使って、MP3 プレーヤを実
装します。このアプリケーションは、USB スタックの
MSD (Mass Storage Device) ホスト コンポーネントを
使って、USB サムドライブを読み出します。グラ
フィック スタックは、タッチスクリーンおよびユーザ
インターフェイス関数を提供します。

本書では、USB およびグラフィック スタックの動作に
ついて説明しません。詳細は関連文書を参照してくださ
い。MP3 レイヤのコアロジックは、AudioUSBTasks.c
ファイル内のAudioUSBTasks()関数でステートマシ
ンとして実装されます。このステートマシンを図 7 に
示します。

「Idle」ステートでは、ステートマシンは USB サムド
ライブが接続されるまで待機します。サムドライブが
接続されると、コードはサムドライブ ファイルシステ
ムの初期化を試みます。アプリケーションは、サムド

ライブ内の MP3 ファイルを検索します。MP3 ファイ
ルが見つかると、そのファイル名が fileNames[]配
列に保存されます。最大で MAX_FILES 個のファイル
名を保存できます。ファイルが見つかると、ディスプ
レイ上のファイルリスト ボックス内のファイル名が
更新されます。最初のファイルが開かれ、コードは
SOF (Start of Frame) の最初のインスタンスを検索し
ます。SOF が見つかった場合、フレームの後続の内容
がファイルから読み出され、そのフレームはデコード
関数へ引き渡されます。デコード済みのオーディオ フ
レームは、再生のために WM8731 オーディオ DAC デ
バイスへ送られます。読み出し / デコード動作がファ
イルの最後に達すると、そのファイルは閉じられて、
次のファイルが開かれます。

currentPlaybackFileIndex変数は、現在処理中の
ファイルを fileNames[]配列へのインデックスとし
て示します。アプリケーションは、[Next] または
[Previous] ボタンの操作に応じてこの変数を変更し、

「Open MP3 File」ステートへジャンプします。

図 7:   AUDIO USB タスクのステートマシン
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デモ アプリケーションの実行
弊社は、本書の内容に対応する MP3 プレーヤ デモ ア
プリケーションのソースコードも提供しています。
MP3プレーヤ アプリケーションは、サンプリング レー
ト 44.1 kHz でエンコードされたステレオ MP3 ファイ
ル をデコードします。これとは異なるサンプリング
レートでエンコードされた MP3 ファイルまたはモノ
ラル エンコードされたMP3ファイルは無視されます。
これはアプリケーションの設計による制限であり、
Helix MP3 デコーダによる制限ではありません。この
デコーダは、MP3 フォーマットが定める全てのビット
レートとサンプリング周波数をサポートします。

MP3 プレーヤ アプリケーションは、マルチメディア
拡張ボード(MEB) (製品番号: DM320005)と、PIC32MX
USB スタータキット II ( 製品番号 : DM320003-2) また
は PIC32 Ethernet スタータキット ( 製品番号 :
DM320004) の組み合わせで動作するよう設計されて
います。マルチメディア拡張ボード (MEB) は 24 ビッ
ト オーディオ用 ADC/DAC とタッチスクリーン ディ
スプレイを実装し、スタータキット コネクタを介して
PIC32MX デバイスをサポートします。詳細について
は、マルチメディア拡張ボードのウェブページ
(www.microchip.com/MEB) をご覧ください。

PIC32MX USB スタータキット II と PIC32 Ethernet ス
タータキットは、PIC32MX795F512L デバイスを使い
ます。このデバイスは 512 Kbyte のプログラム フラッ
シュメモリと 128 Kbyte のデータ RAM を実装してい
ます。また、USB モジュールも実装しています。ス
タータキットは、USB ホストおよびデバイス コネク
タを備えています。

デモ ソースコードを評価するには、MP3 ファイルを
保存した USB サムドライブとステレオ ヘッドフォン
が必要です。MP3 ファイルは、サムドライブのルート
ディレクトリに保存する必要があります。

デモ アプリケーションのコンパイルと
デバイスへのプログラミング
以下では、MP3 プレーヤデモをコンパイルして
PIC32MX デバイスにプログラミングするための手順
について説明します。これは PIC32MX USB スタータ
キット II を使う場合の手順です。PIC32 Ethernet ス
タータキットを使う場合、MEB ENET USB Thumb
Drive MP3 Demo.mcw MPLAB IDE ワークスペース
ファイルを使います。デモのコンパイルおよび実行方
法は、どちらのボードでも同じです。以下の説明は、
ユーザがMPLAB® IDEの使用に習熟している事を前提
とします。

1. MPLAB IDE を開く。Configure>Settings をクリッ
クする。[Projects] タブを開き、「Use one-to-one
project-workspace model」のチェックマークを外
す ( 図 8 参照 )。[OK] をクリックする。

図 8:   MPLAB® IDE の「SETTINGS」ウィンドウ

2. Configure>Settings をクリックする。[Program
Loading] タブを開く。「Clear program memory
upon loading a program」のチェックマークを外
す ( 図 9 参照 )。

図 9:   MPLAB® IDE の「SETTINGS」ウィンド
ウ /「PROGRAM LOADING」タブ

3. File>Open Workspace をクリックして MPLAB
IDE ワークスペース ファイル「MEB USB Thumb
Drive MP3 C32 Demo.mcw」を開く。アプリ
ケーション プロジェクトが MPLAB IDE に読み込
まれる。

4. 「Project Explorer」ウィンドウに、ワークスペー
ス内の 2 つのプロジェクトが表示される。「Helix
MP3 Decoder PIC32.mcp」プロジェクトは、
PIC32MX マイクロコントローラ上での実行用に
変更されたHelix MP3デコーダ ソースコードで構
成される。

5. 「Helix MP3 Decoder PIC32.mcp」プロジェ
クトを右クリックし、開いたメニューから「Set
Active」を選択する ( 図 10 参照 )。 
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図 10:   プロジェクトをアクティブにする

6. デバッガもプログラマも選択されていない事を確
認する。「Debug/Release」の選択は動作に影響せ
ず、無視される。「Build All」オプションを使って、
プロジェクトをコンパイルおよびビルドする。

7. 「MEB USB Thumb Drive MP3 C32 Demo.mcp」
プロジェクトを右クリックし、開いたメニューか
ら「Set Active」を選択する。

8. PIC32 USBスタータキット IIをMEBに接続する。
ファスナーを使って、スタータキットをソケット
に確実に固定する。 

9. スタータキットのデバッグ USB ポートを PC の
USB ポートに接続する。 

10. MPLAB IDE で Debugger>Select Tool>PIC32
Starter Kit をクリックし、PIC32 スタータキット
をデバッガとして選択する ( 図 11 参照 )。

図 11:   デバッガを選択する

11. プロジェクトをコンパイルおよびビルドする。

12. PIC32MX デバイスにプログラミングする。MPLAB
IDEは以下の2つのHEXイメージをデバイスにプ
ログラミングする。

•Helix MP3 Decoder PIC32.elf
•MEB USB Thumb Drive MP3 C32 Demo.elf

13. この手順は必須ではありません : 以下の方法で、
プログラムメモリのアドレス0x9D06E000の内容
を確認する。
MPLAB IDE で View>Memory をクリックし、

「Memory」ウィンドウ内の [Data View] をクリッ
クする。「Memory」ウィンドウ内で右クリックし
て「Go To」を選択し、アドレスとして0x9D06E000
を入力する。「Memory」ウィンドウは図 12 のよ
うに表示される。文字列「Helix Library」が表示
されれば、デバイスへのプログラミングは成功し
た。

以上で、デモ アプリケーションの使用準備が完了しま
す。

図 12:   プログラムメモリの内容を表示する
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デモ アプリケーションの実行
MEB 上のヘッドフォン ジャックにヘッドフォンを接
続し、MPLAB IDE で [Run] をクリックし、MEB 上の
タッチスクリーンを観察します。図 13 に、MP3 プレー
ヤ デモ アプリケーションの GUI を示します。

PIC32MX USB スタータキット II の USB ホスト レセ
プタクルに USB サムドライブを差し込みます。プレ
イリストは、MP3 ファイルと一緒にサムドライブの
ルート ディレクトリに保存されます。アプリケーショ
ンは、プレイリスト内の最初の MP3 ファイルの再生
を開始します。 

タッチスクリーン ボタンの機能は以下の通りです。

• 音量調整用スライダ 
• [STOP] ボタン : MP3 ファイルの再生を停止する。

• [PLAY] ボタン : 再生中にこのボタンを押すと再生は
一時停止し、もう一度押すと再開する。

• [UP]/[DOWN] ボタン : プレイリスト内のファイルを
スクロールする。プレイリスト内のファイルにタッ
チする事で、再生するファイルを選択する。

図 13:   MP3 プレーヤ デモ アプリケーションの GUI レイアウト
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プロジェクト ファイル
本書に付属するソースコード ( 補遺 A:「ソースコード」
参照 ) には、PIC32MX USB スタータキット II と
PIC32MX Ethernet スタータキット向けのデモ用ソー
スコードが含まれています。

「MEB USB Thumb Drive MP3 Demo」フォルダ内の
アプリケーションは、PIC32MX USB スタータキット II
を接続した MEB 上で動作します。「MEB ENET USB
Thumb Drive MP3 Demo」フォルダ内のアプリケー
ションは、PIC32MX Ethernet スタータキットを接続
した MEB 上で動作します。 

表 3 に示したフォルダとファイルの説明は、両方のア
プリケーション フォルダに適用されます。アプリケー
ションによって異なる部分は明示しています。

まとめ
オープンソースの Helix MP3 デコーダは、Microchip 社
のPIC32MX 32ビット マイクロコントローラに移植可
能です。本書では Helix デコーダ API について説明し、
本書に付属する MP3 プレーヤ アプリケーションを
使って Helix MP3 デコーダのデモを実行する方法を紹
介しました。また、RTLL方式についても解説しました。

表 3:  ソースコード ファイルとフォルダ

名称 概要

h MEB USB Thumb Drive MP3 C32 Demoプロジェクト
に必要なインクルード ファイルを格納したフォルダ

lib USBおよびグラフィック スタックのアーカイブを格納し
たフォルダ

obj テンポラリ BSP (Board Support Package) オブジェクト
ファイルを保存するフォルダ

src MEB USB Thumb Drive MP3 C32 Demoプロジェクト
に必要なソースファイルを格納したフォルダ

MP3 Decoder Source Code Helix MP3 デコーダのソースコードを格納したフォルダ

procdefs.ld MEB USB Thumb Drive MP3 C32 Demoおよび Helix
MP3 Decoder PIC32 MPLAB IDEプロジェクトで必要
な変更済みリンカスクリプト ファイル

MEB USB Thumb Drive MP3 C32 Demo.mcp
または
MEB ENET USB Thumb Drive MP3 Demo.mcp

MPLAB IDEプロジェクト ファイル

MEB USB Thumb Drive MP3 C32 Demo.mcw
または
MEB ENET USB Thumb Drive MP3 Demo.mcw

MPLAB IDEワークスペース ファイル

CleanUp.bat テンポラリ ファイルをクリアするためのバッチファイル

MAL BSP Files Archive.bat BSP アーカイブを更新およびビルドするためのバッチ
ファイル

MAL GFX Stack Archive.bat グラフィック スタック アーカイブを更新およびビルド
するためのバッチファイル

MAL USB Stack Archive.bat USBスタック アーカイブを更新およびビルドするための
バッチファイル

Readme.txt デモの実行に関する情報を収めたファイル

Alternative Configurations MEB グラフィック ディスプレイに必要なインクルード
ファイルを格納したフォルダ
DS01367A_JP - p. 16  2014 Microchip Technology Inc.
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補遺 A: ソースコード

本書に関連する全てのソフトウェアは、1 つの WinZip
ファイルに収められています。このファイルは、下記の
Microchip 社ウェブサイトからダウンロードできます。

www.microchip.com
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